OSCam & CCcamAide pour script de lancement Cccam + OSEmu

djay
Membre API-Geek.com
Membre API-Geek.com
Messages : 18
Inscription : 01 juil. 2013, 14:39
A remercié : 6 fois
A été remercié : 1 fois

Aide pour script de lancement Cccam + OSEmu

#1

Message par djay » 10 mai 2014, 11:56

Bonjour,

J'essaye de coupler Cccam2.3.0 et OSEmu (mini emu qui permet de d ouvrir la TNT et les chaines suisses)
pour éviter de lancer en telnet OSEmu j'essaye de modifier le script de lancement mais cela ne fonctionne pas, quelqu un peut
il me dire ou jai fait une erreur ?? :naughty:

ma config : dream 500HD + Newnigma2

Code : Tout sélectionner

#!/bin/sh########################################
###### Powered by NewNigma2 Team ######
### http://newngima2.to ###
########################################


# EMUNAME is only Display name for EMU Menu
EMUNAME="CCcam 2.3.0 OSEmu"
# CCcamversion
CCVer="CCcam2.3.0"
OSEmuVer="OSEmu"


remove_tmp ()
{
[ -e /tmp/ecm.info ] && rm -rf /tmp/ecm.info
[ -e /tmp/ecm0.info ] && rm -rf /tmp/ecm0.info
[ -e /tmp/ecm1.info ] && rm -rf /tmp/ecm1.info
[ -e /tmp/.CCcam.nodeid ] && rm -rf /tmp/.CCcam.nodeid
[ -e /tmp/warnings.txt ] && rm -rf /tmp/warnings.txt
}


case "$1" in
start)
echo "[SCRIPT] $1: $EMUNAME"
if [ `pidof $CCVer | wc -l` == 1 ]; then
echo "[0;31m $CCVer already running...[0m"
else
/usr/bin/$CCVer
sleep 1
/usr/bin/OSEmu -a server:passwd -p 12345 -b
fi
;;
stop)
echo "[SCRIPT] $1: $EMUNAME"
if [ `pidof $CCVer | wc -l` == 0 ]; then
echo "[0;31m $CCVer not running...[0m"
else
kill `pidof $CCVer`
sleep 2
fi 
if [ `pidof $CCVer | wc -l` == 1 ]; then
kill -9 `pidof $CCVer`
fi
if [ `pidof $OSEmuVer | wc -l` == 1 ]; then
kill -9 `pidof $OSEmuVer`
fi 
remove_tmp
;;
restart)
$0 stop
sleep 2
$0 start
;;
*)
echo "[0;32m Usage: $0 start|stop|restart[0m"
exit 1
;;
esac


exit 0


CCcam 2.3.0 /Oscam (dernière MAJ) / Newnigma2 v4.0.10/ dream 500HD

Avatar de l’utilisateur
OniK
Administrateur
Administrateur
Messages : 5063
Inscription : 03 avr. 2013, 19:32
A remercié : 361 fois
A été remercié : 1814 fois
Genre :
Zodiac :
Âge : 36
Contact :
Belgium

Re: Aide pour script de lancement Cccam + OSEmu

#2

Message par OniK » 11 mai 2014, 12:53

pas certain que ca marche avec cccam ...
鬼に金棒

Avatar de l’utilisateur
macmah2
Membre API-Geek.com
Membre API-Geek.com
Messages : 5
Inscription : 16 avr. 2014, 08:24
A remercié : 3 fois
A été remercié : 1 fois

Re: Aide pour script de lancement Cccam + OSEmu

#3

Message par macmah2 » 11 mai 2014, 17:01

Salut
J'ai tester avec ccam 2.1.1/ 2.1.3 / 2.30 aucun soucis ...
Ça tourne avec une Lligne du genre
L: IP Démo 1234 user pass
Pour le script essaye Ca:

Code : Tout sélectionner

#!/bin/sh

CAMNAME="CCcam_2.3.0/OSEmu"

remove_tmp () {
    rm -rf /tmp/*.info* /tmp/*.tmp*
}

case "$1" in
    start)
    echo "[SCRIPT] $1: $CAMNAME"
    remove_tmp
    /usr/bin/OSEmu -a user:pass -p 1234 -b &
    /usr/bin/CCcam_230 &
    ;;
    stop)
    echo "[SCRIPT] $1: $CAMNAME"
    killall -9 OSEmu CCcam_230 2>/dev/null
    sleep 1
    remove_tmp
    ;;
    *)
    $0 stop
    exit 0
    ;;
esac

exit 0

djay
Membre API-Geek.com
Membre API-Geek.com
Messages : 18
Inscription : 01 juil. 2013, 14:39
A remercié : 6 fois
A été remercié : 1 fois

Re: Aide pour script de lancement Cccam + OSEmu

#4

Message par djay » 11 mai 2014, 18:34

Merci pour ton aide mais le script ne lance ni l emu cccam ni OSEMu...
je confirme que cela fonctionne car je peux lancer via telnet et cccam 2.3.0
ca marche, pour les autre versions je ne pensais pas (vu qu il s agit d ECM long pour la tnt)

je remet le script de l emu cccam 2.3.0 par defaut si cela peut t inspirer car j essaye depuis 1 semaine :(

Code : Tout sélectionner

#!/bin/sh
########################################
###### Powered by NewNigma2 Team  ######
###      http://newngima2.to         ###
########################################

# EMUNAME is only Display name for EMU Menu
EMUNAME="CCcam 2.3.0"
# CCcamversion
CCVer="CCcam2.3.0"


remove_tmp ()
{
        [ -e /tmp/ecm.info ] && rm -rf /tmp/ecm.info
        [ -e /tmp/ecm0.info ] && rm -rf /tmp/ecm0.info
	[ -e /tmp/ecm1.info ] && rm -rf /tmp/ecm1.info
        [ -e /tmp/.CCcam.nodeid ] && rm -rf /tmp/.CCcam.nodeid
        [ -e /tmp/warnings.txt ] && rm -rf /tmp/warnings.txt
}

case "$1" in
        start)
                echo "[SCRIPT] $1: $EMUNAME"
		if [ `pidof $CCVer | wc -l` == 1 ]; then
			echo "[0;31m $CCVer already running...[0m"
		else
                	/usr/bin/$CCVer
		fi
                ;;
        stop)
                echo "[SCRIPT] $1: $EMUNAME"
		if [ `pidof $CCVer | wc -l` == 0 ]; then
			echo "[0;31m $CCVer not running...[0m"
		else
			kill `pidof $CCVer`
			sleep 2
		fi	        
		if [ `pidof $CCVer | wc -l` == 1 ]; then
			kill -9 `pidof $CCVer`
		fi							
		remove_tmp
                ;;
        restart)
                $0 stop
                sleep 2
                $0 start
                ;;
     	*)
		echo "[0;32m Usage: $0 start|stop|restart[0m"
		exit 1
		;;
esac

exit 0
et voila le script que j'ai modifié (mais qui ne fonctionne pas..)

Code : Tout sélectionner

#!/bin/sh########################################
###### Powered by NewNigma2 Team ######
### http://newngima2.to ###
########################################


# EMUNAME is only Display name for EMU Menu
EMUNAME="CCcam 2.3.0 OSEmu"
# CCcamversion
CCVer="CCcam2.3.0"
OSEmuVer="OSEmu"


remove_tmp ()
{
[ -e /tmp/ecm.info ] && rm -rf /tmp/ecm.info
[ -e /tmp/ecm0.info ] && rm -rf /tmp/ecm0.info
[ -e /tmp/ecm1.info ] && rm -rf /tmp/ecm1.info
[ -e /tmp/.CCcam.nodeid ] && rm -rf /tmp/.CCcam.nodeid
[ -e /tmp/warnings.txt ] && rm -rf /tmp/warnings.txt
}


case "$1" in
start)
echo "[SCRIPT] $1: $EMUNAME"
if [ `pidof $CCVer | wc -l` == 1 ]; then
echo "[0;31m $CCVer already running...[0m"
else
/usr/bin/$CCVer
sleep 1
/usr/bin/OSEmu -a server:passwd -p 12345 -b
fi
;;
stop)
echo "[SCRIPT] $1: $EMUNAME"
if [ `pidof $CCVer | wc -l` == 0 ]; then
echo "[0;31m $CCVer not running...[0m"
else
kill `pidof $CCVer`
sleep 2
fi 
if [ `pidof $CCVer | wc -l` == 1 ]; then
kill -9 `pidof $CCVer`
fi
if [ `pidof $OSEmuVer | wc -l` == 1 ]; then
kill -9 `pidof $OSEmuVer`
fi 
remove_tmp
;;
restart)
$0 stop
sleep 2
$0 start
;;
*)
echo "[0;32m Usage: $0 start|stop|restart[0m"
exit 1
;;
esac


exit 0  
CCcam 2.3.0 /Oscam (dernière MAJ) / Newnigma2 v4.0.10/ dream 500HD

Avatar de l’utilisateur
OniK
Administrateur
Administrateur
Messages : 5063
Inscription : 03 avr. 2013, 19:32
A remercié : 361 fois
A été remercié : 1814 fois
Genre :
Zodiac :
Âge : 36
Contact :
Belgium

Re: Aide pour script de lancement Cccam + OSEmu

#5

Message par OniK » 13 mai 2014, 14:50

test ca
Contenu caché
Vous devez être inscrit et connecté sur ce forum pour voir le contenu caché.
鬼に金棒

djay
Membre API-Geek.com
Membre API-Geek.com
Messages : 18
Inscription : 01 juil. 2013, 14:39
A remercié : 6 fois
A été remercié : 1 fois

Re: Aide pour script de lancement Cccam + OSEmu

#6

Message par djay » 15 mai 2014, 20:45

J'ai à nouveau testé Onik mais l'emu ne se lance pas (même cccam)

ce n'est pas grave, je suis passé sous Oscam et j'ai configuré un reader pour lire ma carte TNT .

Cela doit venir de mon image.... encore merci pour le temps passé sur mon cas ! :D
CCcam 2.3.0 /Oscam (dernière MAJ) / Newnigma2 v4.0.10/ dream 500HD

Répondre

Revenir à « OSCam & CCcam »