OSCam & CCcamServeur Linux + Oscam: délais lents sur certaines chaines

Répondre
Avatar de l’utilisateur
Sinedbret
Donateur
Donateur
Messages : 25
Inscription : 16 mai 2013, 16:49
A été remercié : 3 fois

Serveur Linux + Oscam: délais lents sur certaines chaines

#1

Message par Sinedbret » 08 oct. 2013, 10:33

Bonjour,

J'ai un serveur OSCAM sur Linux qui tourne depuis des mois sans problème. Depuis quelques jours, je constate de délais assez longs sur les réponses de certaines chaines. Ces délais deviennent tellement longs que ça provoque des freeze. J'ai plusieurs carte Telesat, une carte CSat et une Sky.
Les problèmes ne se posent apparemment que sur CSAT.
Je ne sais pas comment je peux diagnostiquer?

Voici mes fichiers de config:

Oscam.conf:

[global]
serverip = 192.168.10.12
usrfile = /etc/oscam/log/oscam.log
logfile = /etc/oscam/log/oscam.log
cwlogdir = /var/log/oscam/cw
emmlogdir = /var/log/oscam/emm
disableuserfile = 0
unlockparental = 1
nice = -1
maxlogsize = 5000
preferlocalcards = 1
saveinithistory = 1
lb_mode = 1
lb_save = 1000
lb_max_ecmcount = 1000
lb_reopen_seconds = 800
lb_savepath = /var/log/oscam/stat
lb_stat_cleanup = 24

[monitor]
hideclient_to = 15
appendchaninfo = 1

[newcamd]
port = 44600@0100:00006D;44400@0500:032830;44301@0963:000000
key = xxxxxxxxxxxxxxxxxxxxxxxxxx

[cs357x]
port = 44200

[cccam]
port = 44100
reshare = 0
version = 2.1.4
nodeid = xxxx

[webif]
httpport = 81
httpuser = xxxxx
httppwd = xxxxxxxxxxxxx
httprefresh = 20
httpallowed = 127.0.0.1,192.168.10.1-192.168.10.255
httphideidleclients = 1

[anticasc]
enabled = 1
numusers = 1
samples = 5
aclogfile = /etc/oscam/log/oscam_ac.log
denysamples = 4

oscam.server:

[reader]
label = tsatint
protocol = pcsc
device = 5
key = 0102030405060708091011121314
caid = 0100
detect = cd
mhz = 300
cardmhz = 300
ident = 0100:00006D
group = 1
emmcache = 1,3,15
blockemm-unknown = 1
lb_weight = 1000
dropbadcws = 1
ratelimitecm = 4
ratelimitseconds = 10


[reader]
label = tsat2
protocol = pcsc
device = 1
key = 0102030405060708091011121314
caid = 0100
detect = cd
mhz = 300
cardmhz = 300
ident = 0100:00006D
group = 1
emmcache = 1,3,15
blockemm-unknown = 1
lb_weight = 1000
dropbadcws = 1
ratelimitecm = 4
ratelimitseconds = 10


[reader]
label = tsat3
protocol = pcsc
device = 2
key = 0102030405060708091011121314
caid = 0100
detect = cd
mhz = 300
cardmhz = 300
ident = 0100:00006D
group = 1
emmcache = 1,3,15
blockemm-unknown = 1
lb_weight = 1000
dropbadcws = 1
ratelimitecm = 4
ratelimitseconds = 10


[reader]
label = sky
protocol = pcsc
device = 3
caid = 0963
boxid = xxxxxxxxxx
ecmwhitelist = 0963:3B,3E,42,44,45,47,4B,4E,4F,5E,5F,53,54,56,61,62,65,66,67,68,69,6A,6B,6C,6D,6F,70,71,72,73,74,76,77,78,79,7A,7C,7D,7E,80,82,85,88,8B
detect = cd
mhz = 500
cardmhz = 500
group = 3
emmcache = 1,3,2
blockemm-unknown = 1
blockemm-g = 1
lb_weight = 1000


[reader]
label = csat
protocol = pcsc
device = 4
caid = 0500
detect = cd
mhz = 500
cardmhz = 357
ident = 0500:032830
aeskeys = 0500@032830:43xxx
group = 2
emmcache = 1,3,15
blockemm-unknown = 1
lb_weight = 1000
auprovid = 032830

Quelqu'un pourrait m'aider SVP.

Je suis un peu perdu.

Merci de votre aide.

Sined



En ligne
Avatar de l’utilisateur
OniK
Administrateur
Administrateur
Messages : 5172
Inscription : 03 avr. 2013, 19:32
A remercié : 367 fois
A été remercié : 1833 fois
Genre :
Zodiac :
Âge : 37
Contact :
Belgium

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#2

Message par OniK » 08 oct. 2013, 10:43

salut

déjà met ma config et précise kel rev t'as ...

et ne montre pas les aes etc ( d’ailleurs y manquai la 3eme clef ... je sais pas si c’était volontaire )
鬼に金棒

Avatar de l’utilisateur
Sinedbret
Donateur
Donateur
Messages : 25
Inscription : 16 mai 2013, 16:49
A été remercié : 3 fois

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#3

Message par Sinedbret » 08 oct. 2013, 11:41

Bonjour,

Merci pour ta réponse rapide.
Quand tu dis met ma config, qu'entends-tu?
Pour la rev, ça va être compliqué pcq sur l'interface web j'ai ça: "OSCAM 1.20-unstable_svn build #0"

Sinedbret

En ligne
Avatar de l’utilisateur
OniK
Administrateur
Administrateur
Messages : 5172
Inscription : 03 avr. 2013, 19:32
A remercié : 367 fois
A été remercié : 1833 fois
Genre :
Zodiac :
Âge : 37
Contact :
Belgium

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#4

Message par OniK » 08 oct. 2013, 12:52

ok ...

je te conseille vivement de passer a ma rev aussi ...

zone-telechargement/oscam-shadow-by-onik-t155.html

met la 8923 ... ( ya des prob sur le code source ds les rev suivant et ma 8950 est touchée aussi )
鬼に金棒

Avatar de l’utilisateur
Sinedbret
Donateur
Donateur
Messages : 25
Inscription : 16 mai 2013, 16:49
A été remercié : 3 fois

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#5

Message par Sinedbret » 08 oct. 2013, 13:51

Penses-tu que cela puisse être lié à des mesures anti-cs?

Tout marchait très bien jusqu'il y a la semaine passée.

En ligne
Avatar de l’utilisateur
OniK
Administrateur
Administrateur
Messages : 5172
Inscription : 03 avr. 2013, 19:32
A remercié : 367 fois
A été remercié : 1833 fois
Genre :
Zodiac :
Âge : 37
Contact :
Belgium

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#6

Message par OniK » 12 oct. 2013, 11:58

c possible faut voir ce que tu fais ... mais pour le moment je peux te dire ki font joujou oui ...
鬼に金棒

Avatar de l’utilisateur
cchriste
Donateur
Donateur
Messages : 6
Inscription : 27 mai 2013, 22:53
A remercié : 2 fois
Zodiac :
Âge : 56
Contact :

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#7

Message par cchriste » 26 oct. 2013, 10:05

Bonjour,
concernant les lenteurs > 900ms, ce retard provient du nombre croissant de EMM stockées sur la carte, qui ne s'effacent pas.
Dans mon cas, j'ai atteint après 3 ans, des temps de 4 secondes. Pour un user cela marche, mais ayant trois VU dans la maison, j'ai commencé à avoir des timeout.
C'était assez coquin comme défaut, car si 2 postes regardaient la même chaine, le cache masquait la chose.
Sans rien changer dans mes configurations, de nouvelles cartes ont rétablit des temps normaux inférieurs à 400ms.
Je suis en train d'écrire un bout de code dans les sources OScam pour cela.
Dès que c'est prêt je poste.

Bonne journée a tous et surtout, merci à tous les contribuants de ce site qui est très chouette.

Charles

Avatar de l’utilisateur
Sinedbret
Donateur
Donateur
Messages : 25
Inscription : 16 mai 2013, 16:49
A été remercié : 3 fois

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#8

Message par Sinedbret » 29 oct. 2013, 09:46

Bonjour,

tu veux dire que la seule solution est de commander une nouvelle carte?
C'est vrai que quand je regarde les entitlements de ma carte j'ai plus de 400 lignes!
Les plus vieilles datent de 2010.

Merci pour ta réponse.

Sinedbret

Avatar de l’utilisateur
cchriste
Donateur
Donateur
Messages : 6
Inscription : 27 mai 2013, 22:53
A remercié : 2 fois
Zodiac :
Âge : 56
Contact :

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#9

Message par cchriste » 12 nov. 2013, 22:32

Bonsoir Sinedbret,

je m'excuse du delai... je n'ai pas vu ton post.
Je pense que cela est une solution, juste que les nouvelles carte on un compteur de zap. c'est à dire qu'un sharing qui depasse une moyenne de plus de 3 cles par 10 secondes sur quelques jours = blocage de la carte.
Je suis en train d'essayer sur une carte "pleine" de faire un clear des EMM.
Quand prêt je ferais un post.
Bonne soirée

Charles

Avatar de l’utilisateur
Sinedbret
Donateur
Donateur
Messages : 25
Inscription : 16 mai 2013, 16:49
A été remercié : 3 fois

Re: Serveur Linux + Oscam: délais lents sur certaines chaine

#10

Message par Sinedbret » 13 nov. 2013, 08:19

cchriste a écrit :Bonsoir Sinedbret,

je m'excuse du delai... je n'ai pas vu ton post.
Je pense que cela est une solution, juste que les nouvelles carte on un compteur de zap. c'est à dire qu'un sharing qui depasse une moyenne de plus de 3 cles par 10 secondes sur quelques jours = blocage de la carte.
Je suis en train d'essayer sur une carte "pleine" de faire un clear des EMM.
Quand prêt je ferais un post.
Bonne soirée

Charles
Bonjour,

Merci de ta réponse.;-)

Sinedbret

Répondre

Revenir à « OSCam & CCcam »