• Sujets actifs  Arrière Vers l'avant Stop Play

PluginsModifier un plugin

Postez ici tout vos plugins, thèmes etc ...
Répondre
angelin
Membre API-Geek.com
Membre API-Geek.com
Messages : 4
Enregistré le : 15 juin 2015, 15:26
Localisation : Maroc
A remercié : 1 fois
A été remercié : 0
Zodiac :
Âge : 63
Contact :
Morocco

Modifier un plugin

#1

Message par angelin » 26 sept. 2018, 14:02

Chers amis,

Est-il possible de modifier un plugin enigma2 pour l'adapter à une autre image ou à un récepteur différent ?
Par exemple adapter enigma2-plugin-extensions-xxx_1.0-r0_vuzero.ipk en enigma2-plugin-extensions-xxx_1.0-r0 vuplus solo.ipk.

Merci à tous.




Avatar du membre
OniK
Administrateur
Administrateur
Messages : 4933
Enregistré le : 03 avr. 2013, 19:32
A remercié : 357 fois
A été remercié : 1785 fois
Genre :
Zodiac :
Âge : 36
Contact :
Belgium

Re: Modifier un plugin

#2

Message par OniK » 26 sept. 2018, 14:11

hello

tout dépend si t'as les fichiers sources ou pas ...
sans tu peux rien faire ... logique ...
par contre avec les fichiers sources tu vires juste les fichiers compilé et ça devrai être bon ( y seront recompile sur ton demo a premier boot )
après faut voir les dépendances etc mais pour un truc simple c généralement suffisant

++
鬼に金棒

angelin
Membre API-Geek.com
Membre API-Geek.com
Messages : 4
Enregistré le : 15 juin 2015, 15:26
Localisation : Maroc
A remercié : 1 fois
A été remercié : 0
Zodiac :
Âge : 63
Contact :
Morocco

Re: Modifier un plugin

#3

Message par angelin » 27 sept. 2018, 20:00

Salut,

Merci pour ta réponse, en fait il s'agit d'un s'agit d'un seul fichier qui m'aurait permis d'enregistrer les streams ,
c'est l'extension "PAU" destiné au vuzero..
Cordialement.
enigma2-plugin-extensions-pau_1.0-r0_vuzero.ipk
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Avatar du membre
OniK
Administrateur
Administrateur
Messages : 4933
Enregistré le : 03 avr. 2013, 19:32
A remercié : 357 fois
A été remercié : 1785 fois
Genre :
Zodiac :
Âge : 36
Contact :
Belgium

Re: Modifier un plugin

#4

Message par OniK » 28 sept. 2018, 07:49

c un bin déjà compile ( et en closed source )
donc ici pas de possibilité de le modifier ...

par contre c du mipsel logiquement donc aucun souci pour l'utiliser sur un autre modèle de vu+ ( hormis les 4k )

a noter qu'il a besoin de ça en dépendance
libgcc1 (>= 4.9.1), libstdc++6 (>= 4.9.1), libc6 (>= 2.20)
si pas dispo sur l'image de ton vu faudra les installer a la main
鬼に金棒

angelin
Membre API-Geek.com
Membre API-Geek.com
Messages : 4
Enregistré le : 15 juin 2015, 15:26
Localisation : Maroc
A remercié : 1 fois
A été remercié : 0
Zodiac :
Âge : 63
Contact :
Morocco

Re: Modifier un plugin

#5

Message par angelin » 29 sept. 2018, 19:00

salut,

j'ai bien suivi tes conseils,néanmoins cela n'a pas fonctionné sur le vu+solo2 avec "architecture non compatible"
comme message,par contre sur le solo "installation terminée" mais toujours pas d'enregistrement,blocage ,freeze,...
je suis tombé sur un site :

http://forums.openpl...ording-problem/
Eingebaut wird pau dann wie folgt:
1. pau nach /usr/bin kopieren und ausführbar machen (755)
2. pau.sh nach /etc/init.d kopieren und ausführbar machen (755)
Bei der Verwendung von FileZilla darauf achten, dass binäre Übertragen ausgewählt wurde (hatte ich bei der Kompilierung von FileZilla nicht bedacht und mich nach dem Fehler "totgesucht").
3. Per Telnet in die Box einloggen und folgenden Befehl eingeben:update-rc.d pau.sh defaults

Finalement le plugin ipk renommé "pau","pau.sh" trouvé sur un autre site,telnet ,reboot, du coup nickel-chrome,j'espère que ça va durer.
Fausse joie, cela ne marche pas sur toutes les chaines,en tous les cas pas sur les chaines "sports".
Peut-être que de simplement renommer le fichier .ipk est la source du blocage ?


Avatar du membre
OniK
Administrateur
Administrateur
Messages : 4933
Enregistré le : 03 avr. 2013, 19:32
A remercié : 357 fois
A été remercié : 1785 fois
Genre :
Zodiac :
Âge : 36
Contact :
Belgium

Re: Modifier un plugin

#6

Message par OniK » 30 sept. 2018, 08:48

angelin a écrit :
29 sept. 2018, 19:00
j'ai bien suivi tes conseils,néanmoins cela n'a pas fonctionné sur le vu+solo2 avec "architecture non compatible"
ha oui en effet l'ipk est uniquement destiné au zero
License: CLOSED
Architecture: vuzero
angelin a écrit :
29 sept. 2018, 19:00
Finalement le plugin ipk renommé "pau","pau.sh" trouvé sur un autre site,telnet ,reboot, du coup nickel-chrome,j'espère que ça va durer.
un ipk est un auto installer si je peux dire ... ici si tu refais tout en manuel ça devrai aussi être ok ...

la ça semble ok chez toi et pour les chaines KO si c des stream il est fort probable k'ils soient locké pour ne pas permettre l’enregistrement
鬼に金棒


Répondre

Retourner vers « Plugins »