OSCam & CCcamCccam cline dans Oscam

googy_anas
Membre API-Geek.com
Membre API-Geek.com
Messages : 9
Inscription : 08 juin 2013, 12:14
A remercié : 4 fois
A été remercié : 1 fois

Cccam cline dans Oscam

#1

Message par googy_anas » 12 juin 2013, 12:26

Bonjour,

Avant d'exposer mon problème, je vous explique la situation :

J'ai un DM500s en cccam (3 clines) qui fonctionne très bien, pas de coupures ni rien. Voulant "évoluer" un peu, j'ai mis de côté mon DM500s pour installer un Spark 990 reloaded tournant sous enigma2 avec oscam.
Je ne vais pas vous prendre la tête avec touuuutes les bidouilles que j'ai essayé (en vain) pour faire marcher la bête, on va simplement supposer que je commence à zéro avec un système vierge.

Maintenant la question est : COMMENT faire pour que mon enigma2 se comporte comme mon DM500s et se connecte directement à mon serveur ???

PS : J'ai suivi une multitude de conseil au niveau de ce site mais, apparemment, ce sont des trucs très avancés pour le resharing / proxy / dvbapi / machin / bidule / ....etc ;)

Merci d'avance pour votre aide



Avatar de l’utilisateur
xyrius
Donateur
Donateur
Messages : 15
Inscription : 09 juin 2013, 17:09
A remercié : 10 fois
A été remercié : 2 fois

Re: Cccam cline dans Oscam

#2

Message par xyrius » 12 juin 2013, 12:58

oscam a besoin de 3 fichiers pour fonctionner
tu mets un oscam minimal et tu retouches au fur et a mesure

oscam.user

[account]
user = localuser
group = 1,2,3,4,5

oscam.conf

[global]
nice = -1

[webif]
httpport = 8880
httpuser = user
httppwd = pass
httprefresh = 15
httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
pidfile = /etc/tuxbox/config/oscam.pid

[dvbapi]
enabled = 1
user = dvbapi
au = 1
boxtype = dreambox

[cccam]
port = 11111
version = 2.1.1


oscam.server

[reader]
label = localserv
protocol = cccam
device = dns ou ip,port
user = user
password = pass
inactivitytimeout = 30
group = 1
cccversion = 2.1.3
cccmaxhops = 5
ccckeepalive = 1


ca doit tourner en sachant que tu te connectes a ton webiff avec
http://ip da ta box:8880
pour se logguer user et pass

pour tes 3 clines tu dupliques le reader et tu renseignes les champs correctement
n oublie pas de relancer oscam apres changements oscam.conf et oscam.server
dm800se -nemesis 110r-oscam 8668
atlas100hd-starsat ace-samsat60-oboxs9-skyboxf3-vu solo
qques multics et oscam sur vps

Avatar de l’utilisateur
Sic58
Membre API-Geek.com
Membre API-Geek.com
Messages : 53
Inscription : 03 mai 2013, 20:36
A remercié : 3 fois
A été remercié : 9 fois

Re: Cccam cline dans Oscam

#3

Message par Sic58 » 12 juin 2013, 13:12

Dans cet exemple, cccam est configuré pour tourner avec port = 11111. Il faut ouvrir ce port en udp et tcp dans le modem/routeur.

Avatar de l’utilisateur
gzusoner
Modérateur
Modérateur
Messages : 288
Inscription : 04 avr. 2013, 10:16
Localisation : Liège, Belgique
A remercié : 109 fois
A été remercié : 80 fois
Zodiac :

Re: Cccam cline dans Oscam

#4

Message par gzusoner » 12 juin 2013, 19:20

Il doit garder le même port que sous cccam si il a des peers à qui il donne.
En tant que client, il ne doit rien ouvrir pour recevoir.
Mais il doit en indiquer un, même non ouvert, car oscam en a besoin.

De plus si ça fonctionnait en cccam, il n'y a pas de changement à faire du côté du router.
Il pourrait même configurer sa webif en 16001 si il le voulait.

Perso je conseille de changer TOUS les ports par défaut.
Décodeurs:
Vu+ Solo2 @VTi 8 - Oscam 1.20 #10627 by OniK
Gigablue 800HDSE @OpenDROID - Oscam 1.20 #9514 by OniK

Ordis :
Macbook Pro Retina, Hackintosh imac 8,1

googy_anas
Membre API-Geek.com
Membre API-Geek.com
Messages : 9
Inscription : 08 juin 2013, 12:14
A remercié : 4 fois
A été remercié : 1 fois

Re: Cccam cline dans Oscam

#5

Message par googy_anas » 12 juin 2013, 20:09

xyrius a écrit :oscam a besoin de 3 fichiers pour fonctionner
tu mets un oscam minimal et tu retouches au fur et a mesure

oscam.user

[account]
user = localuser
group = 1,2,3,4,5

oscam.conf

[global]
nice = -1

[webif]
httpport = 8880
httpuser = user
httppwd = pass
httprefresh = 15
httpallowed = 127.0.0.1,192.168.0.0-192.168.255.255
pidfile = /etc/tuxbox/config/oscam.pid

[dvbapi]
enabled = 1
user = dvbapi
au = 1
boxtype = dreambox

[cccam]
port = 11111
version = 2.1.1


oscam.server

[reader]
label = localserv
protocol = cccam
device = dns ou ip,port
user = user
password = pass
inactivitytimeout = 30
group = 1
cccversion = 2.1.3
cccmaxhops = 5
ccckeepalive = 1


ca doit tourner en sachant que tu te connectes a ton webiff avec
http://ip da ta box:8880
pour se logguer user et pass

pour tes 3 clines tu dupliques le reader et tu renseignes les champs correctement
n oublie pas de relancer oscam apres changements oscam.conf et oscam.server
MERCIIIIII, ça marche impeccablement automagiquement bien !!!

Encore merci à tous

googy_anas
Membre API-Geek.com
Membre API-Geek.com
Messages : 9
Inscription : 08 juin 2013, 12:14
A remercié : 4 fois
A été remercié : 1 fois

Re: Cccam cline dans Oscam

#6

Message par googy_anas » 12 juin 2013, 20:11

MERCI @xyrius , @gzusoner , @Sic58 et bien sûr API-GEEK

Avatar de l’utilisateur
xyrius
Donateur
Donateur
Messages : 15
Inscription : 09 juin 2013, 17:09
A remercié : 10 fois
A été remercié : 2 fois

Re: Cccam cline dans Oscam

#7

Message par xyrius » 13 juin 2013, 20:12

hi
content pour toi que ca marche
personnalise les ports ,pass et users sait on jamais
dm800se -nemesis 110r-oscam 8668
atlas100hd-starsat ace-samsat60-oboxs9-skyboxf3-vu solo
qques multics et oscam sur vps

Répondre

Revenir à « OSCam & CCcam »